Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Android version not compatible with Tello FPV app

Rbicho

New member
Joined
Aug 27, 2019
Messages
3
Reaction score
2
Hi, I have recently bouth a Tello drone and would like to use it with the Tello FPV app. I started the download process in a Samsung SM-T330 table but got the message that the device does not support the app.
Can anybody help me how to overcome this?
Thanks
 

ZWActual

Well-known member
Joined
Jul 8, 2019
Messages
254
Reaction score
137
Location
Witless Protection
Welcome. There may be a few reasons why that message typically comes up.
  • Apps are marked as compatible with certain phones/tablets but they should run fine on unsupported devices.
  • All apps require a minimum version of the Android OS for it to run.
Assuming the Samsung SM-T330 is up to date or running the latest Android OS, TelloFPV would still install on that device and run accordingly.

Have TelloFPV running on the phone (Android 9.0) predominantly but have also tested on an Android 7.0 tablet.

Keep us posted on how it goes.
 
  • Like
Reactions: umanbean

Rbicho

New member
Joined
Aug 27, 2019
Messages
3
Reaction score
2
Thanks for the quick feedback.
I’m not even able to install it. The tablet has the most updated Android version which is 4.4.2
I guess it is too old to support tue app
 
  • Like
Reactions: umanbean

ZWActual

Well-known member
Joined
Jul 8, 2019
Messages
254
Reaction score
137
Location
Witless Protection
Hmmm. Yeah, Android 4.4.2 (KitKat) was released in 2013.

There are devices that can perform a firmware update via side-loading but don't believe the T330 can. Also, caveat emptor.

Your best bet would be to acquire an inexpensive Android device on the secondary market.

Good luck!
 
  • Like
Reactions: umanbean

Rbicho

New member
Joined
Aug 27, 2019
Messages
3
Reaction score
2
Thanks. Just saw that TelloFPV only supports 5.0 and above. Already searching for a cheap tablet.
Cheers
 
  • Like
Reactions: umanbean

umanbean

Well-known member
Joined
Nov 5, 2018
Messages
423
Reaction score
233
Age
64
Location
Georgia, US
Thanks. Just saw that TelloFPV only supports 5.0 and above. Already searching for a cheap tablet.
Cheers
You beat me to it lol, I was just about to reply and say that 5.0 is minimum.

My current phone and tablet run Tellofpv just fine but I have an old Galaxy S3 (4.4) I'd like to run it on also. I've looked into rooting it and installing a later OS but no luck yet... just don't have the time to chase down all the details, and besides it's my dedicated music streamer and I don't want to chance bricking it!

Good luck in your shopping for a later device!
 

New Threads

Members online

Forum statistics

Threads
3,340
Messages
25,957
Members
8,620
Latest member
drikus