Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Camera not working

Adnanzoraiz

New member
Joined
Feb 6, 2020
Messages
2
Reaction score
0
Hi...my tello connects to my phone...got updated to new firmware,flies ok all functions working but no pocture from camera seen on the phone and app screen
Also even after fully charging the battery...app shows battery icon red and empty....i bought it one year back but never used it....i remember using it the day i got it and camera was ok....can it be that over the time battery has gone bad due no usage and thats why camera doesnt work sensing the low/bad battery???help will be highly appreciated
 
I think thats the problem on your phone. I would recommend trying to reinstall the app or try flying with another phone. If that doesnt help that means the drone is the problen and you will need to send it back to ryze for repair

Wysłane z mojego SM-G930F przy użyciu Tapatalka
 
Also that could be because the 3rd connection on the battery (the middle one) is broken and the tello has issues

Wysłane z mojego SM-G930F przy użyciu Tapatalka
 
Hey I am kinda having the same trouble with my tello. I started to charge it up in my boost combo. When it was charged i put it into my drone. I held the button for around five seconds until the green light turned off. suddenly a red light came on. It was kind of blinking but it was more like it was fading away and then getting brighter again. I watched some vids and it said it was meant to be a yellow light flashing. bit I could still connect my iPad/phone to the WiFi. I when back on the app. There was no picture from the camera and it said it had no power. Now i have been trying for 6 hours and still can’t make it work?
 
I have same problem with my tello. :confused:
Could anyone solve this problem? Could you share the procedure to solve it?
 
Hey I am kinda having the same trouble with my tello. I started to charge it up in my boost combo. When it was charged i put it into my drone. I held the button for around five seconds until the green light turned off. suddenly a red light came on. It was kind of blinking but it was more like it was fading away and then getting brighter again. I watched some vids and it said it was meant to be a yellow light flashing. bit I could still connect my iPad/phone to the WiFi. I when back on the app. There was no picture from the camera and it said it had no power. Now i have been trying for 6 hours and still can’t make it work?
I dont know if you have already fixed the problem but you accidentally put the drone into its like "force firmware update mode." this is for when the drone is really buggy and you want to reinstall the firmware. If you want to start the drone up normally hold that power button for a second and then let go and it should be normal :D
 
Hey I just got my drone its a boost. I updated it and everything but the camera doesn't work. It shows pictures I take but that's it. Can you help me out?
 
Try this: activate flight mode on the phone, re-enable only wifi, select the Tello wifi and start the app.

If that doesn't work: try TelloFPV with the same procedure above. There is a free demo version so you can try before you purchase the real app (on Android only because Apple doesn't allow free trial version).
 

Members online

No members online now.

Forum statistics

Threads
5,716
Messages
40,020
Members
17,157
Latest member
rigocbr