Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

drone keeps flying backwards

Rom13IL

Member
Joined
Dec 21, 2020
Messages
7
Reaction score
1
Hey, hope everyone's day has been well today!

My tello somtimes (quite often tho) just start to fly backwards and a bit to the right while hovering.. It did crush quite a bit so I replaced the propellors but it didn't seem to change anything.. Is there another way to fix it? i tried the IMU test thingy on the offecial app and it flashed a green light on every state so I am kinda lost...

Would programming it to fly a bit to the oppisete side be affective? and how hard would it be if it is? It doesn't sound reasonable to me to make it but if I am wrong i will try it out..

It doesn't seem to constant too, so i tried also flying it with windows closed, with the official app, with extra phone lighting and none of them seem to work so I am a bit worried because I am using it for the end project in my school...

Thanks and sorry if this question may have been already asked, I just didn't find an appropriate solution
 

chord8

Well-known member
Joined
Dec 19, 2020
Messages
45
Reaction score
6
Hey, hope everyone's day has been well today!

My tello somtimes (quite often tho) just start to fly backwards and a bit to the right while hovering.. It did crush quite a bit so I replaced the propellors but it didn't seem to change anything.. Is there another way to fix it? i tried the IMU test thingy on the offecial app and it flashed a green light on every state so I am kinda lost...

Would programming it to fly a bit to the oppisete side be affective? and how hard would it be if it is? It doesn't sound reasonable to me to make it but if I am wrong i will try it out..

It doesn't seem to constant too, so i tried also flying it with windows closed, with the official app, with extra phone lighting and none of them seem to work so I am a bit worried because I am using it for the end project in my school...

Thanks and sorry if this question may have been already asked, I just didn't find an appropriate solution
Try a recalibration of all the characteristics,,
 

EssexFlyer

Member
Joined
Feb 2, 2021
Messages
17
Reaction score
8
Location
Essex, UK
Change all the props, the correct ones on the correct motor. Clean the two VPS sensors underneath. Make sure in airplane mode.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
5,115
Messages
36,996
Members
13,829
Latest member
ahnic