Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Gamesir G3s Not Working w/ Tello App

Supersonic

Member
Joined
Mar 16, 2018
Messages
11
Reaction score
1
Bluetooth on, already synced w/ phone. Startup Tello, I tap on "Gamesir-G3GCM". Get "Connection Failed" with Chinese toast.

Screenshot_2018-03-19-12-18-47.png
 

Netfolks2000

Well-known member
Joined
Mar 3, 2018
Messages
121
Reaction score
38
See other posts. The GameSir T1D is the one to watch for and it is not out yet. It will come out first on the DJI web store.
 
  • Like
Reactions: Supersonic

Supersonic

Member
Joined
Mar 16, 2018
Messages
11
Reaction score
1
Right, what Netfolks2000 said when I contacted their support, same message, GameSir T1D only. It comes out this month or next.

So if controllers are your vice with the tello...you only have one option at the moment </pun>
 

Cyke

Member
Joined
Jun 23, 2018
Messages
14
Reaction score
2
Bluetooth on, already synced w/ phone. Startup Tello, I tap on "Gamesir-G3GCM". Get "Connection Failed" with Chinese toast.

View attachment 58
Hello ,
Try to put a micro USB cable to your Bluetooth gamesir joystick G3s and put the other extremity to the OTG Android device.
After that you have to use the aTello application (unofficial) from Krag. Don't use the official application ( it recognize not your Bluetooth joystick)
 

wizOfWas

New member
Joined
Jul 1, 2018
Messages
3
Reaction score
1
Using android Pixel 2, I just now got my gamesir G4S working with the official Tello app.
It hasn't worked except for in the alternative "aTello" app or with the gamesir device remapping thing. Anyway, I broke down and got the gamesir T1d... but it didn't work either! This solved it for both.

The key tip for me was NOT PAIRING IT IN THE PHONE'S BLUETOOTH SETTINGS. The Tello App does the pairing.

1) uninstall Tello app
2) in bluetooth "forget" the gamesir-G4S (if you had it connected from within the phone's bluetooth settings)
3) reboot phone
4) install Tello app - accept permissions(for me they disappeared too quickly did step below)
5) make sure blue tooth is on -- but do not try to do anything in the bluetooth settings
6) go to settings -> "Apps & Notifications" -> Tello app accept permissions (Storage and Location)
7) Power-on the gamesir
8) open Tello app -> Settings -> Bluetooth controller - click on the the gamesir
go to main screen and the on-screen joysticks will be gone.

Anway, you don't need to turn the Tello itself on to get the paring done and see that it works.

After all that initial paring ordeal, it works super quickly - I can go to the Tello App's "bluetooth controller setup" screen, turn on the gamesir, and it shows up in seconds. Still have to tap it to get it connected, but this just takes a second.

Wiz
 
  • Like
Reactions: Beire

ral67

Active member
Joined
Jul 15, 2018
Messages
28
Reaction score
6
For me a GameSir G3s works fine on iPhone IOS with Tello app
 

New Threads

Members online

Forum statistics

Threads
3,525
Messages
27,130
Members
9,172
Latest member
randsomman