Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

New motors

Pollax

Well-known member
Joined
Jul 28, 2018
Messages
54
Reaction score
31
Ok so at last my new motors have arrived. They are racestar 8520 motors, let's see how these will hold up.

Only fast tested one of them but it will fly stable even when I only changed one.

Not soldered anything yet (original motors fried fast) for Quick replace when these motors fail. Anyways will be fun testing them all later. I think they have higher rpm then original.
 

Attachments

  • IMG_20180824_142705.jpg
    IMG_20180824_142705.jpg
    1.6 MB · Views: 34
  • IMG_20180824_142809.jpg
    IMG_20180824_142809.jpg
    1.8 MB · Views: 36
  • IMG_20180824_142926.jpg
    IMG_20180824_142926.jpg
    2 MB · Views: 40

yechuperka

Member
Joined
Aug 21, 2018
Messages
19
Reaction score
29
Location
Russia, Kaliningrad
I saw same but in black color, will try it when my stock motors will be roasted. It's a pain that Ryze did not implement sockets for the motors and we have to choose between soldering on the board vs that ugly wires sticking from Tello.
 
  • Like
Reactions: Pollax

BKKKevin

Member
Joined
Jul 24, 2018
Messages
16
Reaction score
8
I used this guys clean & simple method of soldering the wires together and tucking the excess into the Tello...

 

Pollax

Well-known member
Joined
Jul 28, 2018
Messages
54
Reaction score
31
First motor (brush problems) within day 3 of owning it. The brushes in one motor was almost fried. Fixed the position of the brushes in all motors but one was in really bad shape. Then it totally died in air as I've shown in a video in this forum. Of course I contacted Ryze and they answerd fast but really did not want to listen on my motor failure after so short time. Anyways did tell them not to bother anymore.. I've got new motors incoming.
 
  • Like
Reactions: Zeno

Pollax

Well-known member
Joined
Jul 28, 2018
Messages
54
Reaction score
31
It is already flying :) now I am thinking about chaning all motors but not today.. A bit lazy on fridays ;)
 
  • Like
Reactions: Zeno

Pollax

Well-known member
Joined
Jul 28, 2018
Messages
54
Reaction score
31
New day better fix.
Soldered the cables into place.
 

Attachments

  • IMG_20180825_133206.jpg
    IMG_20180825_133206.jpg
    5 MB · Views: 44
  • IMG_20180825_133122.jpg
    IMG_20180825_133122.jpg
    4.9 MB · Views: 43
  • Like
Reactions: Beire

Pollax

Well-known member
Joined
Jul 28, 2018
Messages
54
Reaction score
31
Thanks, though now I am in the ryze support about the latest firmware issue.
Like so many others, fast mode gets slow after a while.
 

New Threads

Members online

Forum statistics

Threads
4,726
Messages
34,570
Members
12,252
Latest member
Sleeperagent