Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Tello Blinks Slow First and then Fast and repeats

Valdas

New member
Joined
Aug 13, 2019
Messages
2
Reaction score
0
I got my Tello, a couple of months ago. I used it for about a month and then stored it away, in the box that it came. Took it out today, didn't turn on, no lights(as expected), but when I put it for charging, the led indicator first blinks blue slowly and then relatively faster and then goes back to slow blinking and this repeats. Put it for charging for about 2 Hours now and the drone doesn't turn on at all when the power button is pressed firmly(no lights at all). Please help me, i tried differents chargers 2A and 3A ant the chargers has 5V output. Nothing helps:/

Video is here VID_20190814_005943.mp4
 

ZWActual

Well-known member
Joined
Jul 8, 2019
Messages
413
Reaction score
220
Location
Witless Protection
Assuming you don't have another battery to see if it's a bad battery, do you have a different micro USB cable to rule out it's not a cable issue?

Also, make sure the battery and micro USB is firmly seated in the respective connectors.
 

Valdas

New member
Joined
Aug 13, 2019
Messages
2
Reaction score
0
Assuming you don't have another battery to see if it's a bad battery, do you have a different micro USB cable to rule out it's not a cable issue?

Also, make sure the battery and micro USB is firmly seated in the respective connectors.
With every cable is the same problem, everything is connected fine. Am, only one battery having now.
 

New Threads

Members online

Forum statistics

Threads
3,634
Messages
27,684
Members
9,486
Latest member
Shroompsy