Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Tello Edu Drone wont take off


New member
Mar 24, 2021
Reaction score
Hey guys

So I just bought a tello edu drone and downloaded the tello app. Went to the remote control to try and control the drone with my phone. Connected via wifi and tapped the take off button, and the drone doesn't take off. The motors don't even spin. Any help would be great.

I have a Samsung Galaxy S20
For future readers. Your drone will not take off in following conditions -
1) Low light
2) Overheated drone
3) Low Battery, sometimes i have tried to take off at a battery level of 20%, it just doesn't work
4) IMU Calibration error
5) Loose wiring
Thanks for your information, anyway your answers all are concerned hardware,
I just bought a new drone tello edu, no any damage, but it doesn't take off, and found log message in tello edu app , showing error message, such as
Send: EXT version?
Send: wifiversion?
Receive: unknown command:EXT
Receive: unknown command:wifiversion?
Send: EXT version?
Send: wifi version?
Receive: unknown command:EXT
Send: Re0201 takeoff
Send: Re0202 takeoff
Send Re0210 takeoff
Send Re0401 Land
Why come out like this even just bought from a shop,
Not sure can it be solved by reset to the factory setting, anyone please help.
I had the same problem with Huawei P20pro. I tried to activate the Tello Edu using the Tello Edu app on a oldest Samsung. It worked. After this the Tello Edu worked also with the Huawei P2pro.
If the Tello app doesn't work for some reason you can use TelloFpv to "activate" the drone on the first connection. On Android the free demo version is sufficient.
No such thing as a free demo on Apple though.

Members online

No members online now.

Forum statistics

Latest member