Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

tello edu missing commands from SDK 2.0 - working on swarm

frenchfry_king

New member
Joined
Jan 15, 2023
Messages
3
Reaction score
0
Hello,

I have a couple Tello EDU drones and am attempting to synchronize their motion with the swarm commands. From my understanding, both drones and the computer need to be connected to the same router, and the program commands the drones simultaneously using their IP addresses. To connect the drones to the router, the command "ap [ssid] [password]" is used to make the drone connect to a separate wifi network. However, whenever I try issuing the ap command, the drone responds with the error: "unknown command: ap". Both drones otherwise work perfectly fine - I was able to get them to takeoff, flip, and land using both packet sender commands and python libraries. If I had never tried using the ap command, I would probably assume the drone is working perfectly fine. Here is a brief overview of the troubleshooting process I went through:
  • The router I have is a really old belkin router from >8 years ago. The router wasn't connected to the internet, just created a local wifi network. I gave it a factory reset and tried the ap command with both an empty string password (like free starbucks wifi with no password), and I also gave the wifi network a simple password and tried the command just in case the second password parameter is required.
  • I tried the ap command with both packet sender (i made sure to send "command" followed by "ap belkin54g 1234") and with the DJITelloPy python library [ connect_to_wifi(self, ssid, password) ]. I got the same "unknown command: ap" through both methods, which was suspicious. The python library should be error free - right?
  • I also tried updating the drone firmware with the app. I first connected by phone to wifi and downloaded the latest update, but when I connected to the offline drone wifi, it said the software was up-to-date.
  • I then started digging even deeper online and found out that the ap command was in SDK 2.0 but not in SDK 1.0 . From my understanding, all Tello EDU models should come pre-installed with sdk 2.0 (correct me if i'm wrong). All the commands from the old SDK 1.0 were working perfectly and I had a lot of fun writing basic python programs for a single drone. I sent the drone a known command followed by unknown parameters to see how it would respond ("flip ejrkjhgs" as opposed to "flip f"). The drone responded with "unknown command: ejrkjhgs", which is what I expected. This leads me to believe the drone doesn't know what the ap command is. Another command missing from SDK 1.0 but present in SDK 2.0 is the "sn?". I sent the drone the sn? command and it responded with "unknown command: sn". From these cases together, I think my tello EDUs might have SDK 1.0 .
For context, these drones were purchased in bulk by my school's robotics lab around Fall 2021, well after the release of SDK 2.0. I am a student working with the drones for my final project and have only learnt about them over the past couple weeks. Any additional troubleshooting suggestions or even confirmation that this is a weird problem would be highly appreciated! Thank you!
 

Hacky

Well-known member
Joined
Jul 19, 2021
Messages
316
Reaction score
123
Location
Germany
Welcome to the challenges of formation programming.

First you should make sure, the Tello EDUs got the latest updates. Meanwhile there is a SDK 3.0 and using it, requires that Tellos are updated to the latest firmware. You find a thread adressing the new features of SDK 3.0 also in this forum.

As a starting point for formations, you should take a look at GitHub - TelloSDK/Multi-Tello-Formation: A Sample Code that implements the formation function of multiple tellos
It also explains the configuration of the drones for connecting to your router. If you go ahead with that example, first you will have to make some modification in order to be compatible to Pyhton 3 (code is still for Python 2).
 

frenchfry_king

New member
Joined
Jan 15, 2023
Messages
3
Reaction score
0
Hi - thanks for your help!

I'm having the same problem with the new Multi-Tello-Formation link - it comes down to the basic "ap" packet command that the drone is fundamentally missing. I attempted updating the drone through the IOS Tello app, but the app says the done is fully updated. Is there any other way to update the Tello EDU?
 

Members online

Forum statistics

Threads
5,573
Messages
39,418
Members
16,263
Latest member
safields12