Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Commands work but not listening to state and video

Neoflash

Member
Joined
Dec 28, 2018
Messages
24
Reaction score
0
Hey guys, would you be kind enough to take a look at the Stack Overflow question I have posted and see if anything jumps at you. I can control the drone. sending and receiving commands and responses on port 8889 but I'm getting nothing from 8890 and 11111 for state and video.

Thanks.
 

JohnWalicki

Member
Joined
Aug 21, 2018
Messages
7
Reaction score
6
@Neoflash - Did you open your firewall to accept UDP ports 8890 / 11111 ?

Open port 8890/udp and 11111/udp in your laptop firewall to receive Tello telemetry data.

On Linux
$ sudo firewall-cmd --permanent --add-port=8890/udp
$ sudo firewall-cmd --permanent --add-port=11111/udp


On Mac, use System Preferences to open the ports.

  • Open System Preferences > Security & Privacy > Firewall > Firewall Options
  • Click the + / Add button
  • Choose 'node' application from the Applications folder and click Add.
  • Ensure that the option next to the application is set to Allow incoming connections.
  • Click OK.
 
  • Like
Reactions: Mike Shock

Neoflash

Member
Joined
Dec 28, 2018
Messages
24
Reaction score
0
@Neoflash - Did you open your firewall to accept UDP ports 8890 / 11111 ?

Open port 8890/udp and 11111/udp in your laptop firewall to receive Tello telemetry data.

On Linux
$ sudo firewall-cmd --permanent --add-port=8890/udp
$ sudo firewall-cmd --permanent --add-port=11111/udp


On Mac, use System Preferences to open the ports.

  • Open System Preferences > Security & Privacy > Firewall > Firewall Options
  • Click the + / Add button
  • Choose 'node' application from the Applications folder and click Add.
  • Ensure that the option next to the application is set to Allow incoming connections.
  • Click OK.
Thank you so much, it never occurred to me that it could have been the Windows firewall that was blocking the ports since 8889 was coming thru just fine. I guess another application had already opened it. I got it fixed now.
 

New Threads

Members online

Forum statistics

Threads
3,233
Messages
25,007
Members
8,333
Latest member
Just8Will