Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Various problems: Drifting of drone in standby, "move to" not working, and video lagging

JoeCorsair

New member
Joined
Apr 21, 2022
Messages
4
Reaction score
0
Hi,

I just got my drone today. I have the basic Tello drone (combo pack), not the EDU drone. I've tried various different python libraries, such as DJITelloPy, TelloPy and tello-asyncio, in order to interact with the drone programmatically.

However, first of all I keep on getting the "invalid IMI" error for any movement that specifies a position. Is that because my drone is not the EDU version? There is enough lighting in the room, so not sure why this would happen. I can still send direct rc commands, so at least I can still move the drone as such.

Secondly, once in the air, my drone doesn't stay nice & stationary like in the videos, but instead tends to drift all over the place. Even up & down. That's quite annoying and I am not sure what to do. I checked all the blades and they're properly installed. I also "calibrated the IMU" but I am not sure that helped at all - it may have made it worse.

Thirdly, the video feed is MASSIVELY delayed when reading the webcam feed programmatically vs the experience on my Android phone. I tried the proposed solution from a member of this forum to separate the video and drone control to separate threads, and also ran this example: tello-asyncio/video_opencv.py at main · robagar/tello-asyncio - to no avail. The video feed is at least 1.5 seconds behind the live action. I should note that I have an extremely beefy PC, so it would seem very unlikely to be a hardware issue. This is the most important issue for me to fix, because I want to apply machine learning on the video feed, and if it is delayed that drastically, then this is impossible to work with. I read that an extender might help, but again, on Android it works, and the drone is right next to the PC, so that's all somewhat weird.

Thanks for your help
 

devdrone

Member
Joined
Apr 8, 2022
Messages
9
Reaction score
1
I am not familiar with the error message but the regular Tello obeys the commands in the SDK 1.3 specification. Moving 20 cm forward is supported but moving to (x,y,z) is not.

I use the mobile Tello FPV app to make sure there is enough light. If it says there is not enough light, turn on more lights. In my room with two windows during the day, the overhead lights must be turned on to get steady hovering.

I have noticed on python-opencv-tello tutorials, before a video frame is processed and displayed, the frame is to down sized and converted to grayscale. This may help reduce the lag. The tutorials I have looked at only use connect, get_battery, takeoff, land, streamon, streamoff, and rc. These commands are all in SDK 1.3 so work with Tello and Tello EDU.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
5,445
Messages
38,863
Members
15,453
Latest member
poldita