Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Dji tello Repair Motor Running on its own

Gusdroner

New member
Joined
Sep 25, 2020
Messages
2
Reaction score
0
My brothers was flying his tello one day and one of the motors flew off when he crashed landed. So I bought a new motor from amazon and watched a few videos on how to install the new one looked pretty easy. Most of the yt videos recommended soldering the wires into the motherboard but I watched one video claiming I could just clip the old wires and tangle the new stripped wire. Here's the video where I got the idea from
looks pretty simple doesn't involve any soldering and it made sense to me. The motors I purchased were from rc geeks. When I finished wrapping the wires together I put the battery inside to see if it went well and the motor began running on it's own. Even tho the tello wasn't turned on the motor was running on by itself. Only the new motor was doing this the rest were normal. The order comes with four motors so I tried each one they all did the same thing. Thinking that the motor was faulty I ended up returning the product and buying a new one different company. This time the order only came with one motor and the exact same thing happened . So I'm wondering what am I doing wrong. Also want to mention that in the video it looks like they remove two motors maybe the drone works in pair motors not sure but like I said when i had the four motors i tried all the motors and even clipped an extra motor like in the video to see maybe it's like the motors are paired so if one goes bad you have to change the pair together but that didn't work either. It looked really simple and I was hoping on fixing it quickly because my brother literally just bought this drone like a week before the accident and now it's been down for months. If someone could help me I would appreciate it highly thanks
 

xaser66

New member
Joined
Aug 31, 2018
Messages
3
Reaction score
3
Hello. Sadly I may guess that the problem might be in the motherboard of tello, due that you made tests with new motors. Also I wonder/guess if you may already checked with inverting the wires of the new motor only for the sake that them may came inverted from factory...
One last resource check... is to use the opposite leg's original motor of your tello and check it on your faulty leg, and the new one on the good leg...if this test goes same as previous on the faulty leg, almost sure the problem is in the motherboard of tello.
Good luck, best regards, and Pura Vida from Costa Rica.
 
  • Like
Reactions: Gusdroner

Dman68

New member
Joined
Jan 12, 2021
Messages
1
Reaction score
0
I have this same problem except a original motor that was in good working order is running on power on. It does not increase speed at lift off either. I replaced the motor next to it and it runs fine but the original is on all the time. I did as many tests that I could think of, cleaned the connections throughly, inspected the motherboard, updated firmware, calibrated, tried different motors, disconnected the new motor, all with the same result. No short anywhere. Time for a new drone.
 

New Threads

Members online

Forum statistics

Threads
5,119
Messages
37,026
Members
13,839
Latest member
teket4