Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Doesn’t take off after crash

Martyin

New member
Joined
Oct 4, 2019
Messages
4
Reaction score
0
Hi,

New here and I need help to know if something can be done to fix my Tello that doesn’t take off anymore. I crashed it into a hedge and it fell to meters into asphalt afterwards. Tello tries to lift intensely but only manages on on side and then stops.


Skickat från min iPhone med Tapatalk
 

ZWActual

Well-known member
Joined
Jul 8, 2019
Messages
382
Reaction score
203
Location
Witless Protection
Welcome @Martyin

Typical troubleshooting suggestions:
  • Are the propellers with the marks placed back on correctly at the 10 and 4 o' clock positions (if they popped off)?
  • Do the props spin freely on their own if you flick them?
  • Do any of the props slow down or stop first if you spin them manually?
  • Are the motor shafts straight or bent? Are the props bent?
  • If you hold the Tello and perform a CSC (Combination Stick Command - where you arm the motors and not take off), does the drone appear to balance itself or does it lift to one side immediately?
 

Woodie_07

Member
Joined
Mar 27, 2019
Messages
6
Reaction score
1
Did you replace the propellers? It sounds like the propellers are on wrong. Make sure the propellers with the marks goes on the arm with the marks. If that doesn’t work, try an IMU calibration.
 

Martyin

New member
Joined
Oct 4, 2019
Messages
4
Reaction score
0
Did you replace the propellers? It sounds like the propellers are on wrong. Make sure the propellers with the marks goes on the arm with the marks. If that doesn’t work, try an IMU calibration.
Yes, I replaced the propellers bit didn’t know about the markings. Went to where I bought it and they replaced the whole drone. Problem solved and wiser now for next time. Thanks a lot for your help!


Skickat från min iPhone med Tapatalk
 

Martyin

New member
Joined
Oct 4, 2019
Messages
4
Reaction score
0
Welcome @Martyin

Typical troubleshooting suggestions:
  • Are the propellers with the marks placed back on correctly at the 10 and 4 o' clock positions (if they popped off)?
  • Do the props spin freely on their own if you flick them?
  • Do any of the props slow down or stop first if you spin them manually?
  • Are the motor shafts straight or bent? Are the props bent?
  • If you hold the Tello and perform a CSC (Combination Stick Command - where you arm the motors and not take off), does the drone appear to balance itself or does it lift to one side immediately?
It lifted to one side and then gave up after increasing the rpm a lot.


Skickat från min iPhone med Tapatalk
 

Martyin

New member
Joined
Oct 4, 2019
Messages
4
Reaction score
0
Did you replace the propellers? It sounds like the propellers are on wrong. Make sure the propellers with the marks goes on the arm with the marks. If that doesn’t work, try an IMU calibration.
Thank you!


Skickat från min iPhone med Tapatalk
 

New Threads

Members online

No members online now.

Forum statistics

Threads
3,429
Messages
26,623
Members
8,880
Latest member
Arsangus3