Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Linux Video Output using gobot?

nikolaevarius

New member
Joined
Aug 1, 2018
Messages
3
Reaction score
0
Has anyone had any problems with Linux and ffmpeg/mplayer video output? I'm trying to get it working but while the drone itself works, I can't can't get video output. No window opens and syslog shows no errors.
 
Has anyone had any problems with Linux and ffmpeg/mplayer video output? I'm trying to get it working but while the drone itself works, I can't can't get video output. No window opens and syslog shows no errors.

I think I was having troubles with that a while ago, can't remember. Are you looking for just something that works on Linux, or specifically something developed by Gobot?

If you're looking for a general solution, @SMerrony 's TelloTerm works well.
 
I'm trying to build a application that leverages both gobot and the generic tello libraries and create a desktop based tello all-in-one solution.

The ffmpeg/mplayer issue probably isn't specific to gobot because I'm just opening a generic stdin/stout and streaming pixels to it. It would be one thing if I got a blank player, but I don't even get a media player window
 
Hi, I can run Gobot examples, but my TELLO starts to move and just after 2 seconds it gets stuck. Is like it loses communications or something. Any idea?
 
Apparently the issue is the fact that I use a terminal that is easily backgroundable. The OpenCV Window is tied to that terminal so if I background it, the OpenCV window goes away. Really really annoying.
 

Members online

No members online now.

Forum statistics

Threads
5,720
Messages
40,028
Members
17,174
Latest member
rocksolid