Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Takes off at a pretty high speed

jcsanabria

New member
Joined
Nov 27, 2020
Messages
1
Reaction score
0
Hi everyone, I have a Tello that I have hardly used. I use it mainly indoors.. Just yesterday I used it several times and I had a soft crash so I decided to recalibrate the drone. I can't remember if the same problem happened before I calibrated but I would have thought that this problem would have been fixed by calibrating Tello. What is happening is that I turn on Tello, then connect it to my iphone, click on the take off icon, slide the option to take off and it really takes off and it hits my house ceiling really hard. Instead of hovering a few meters above ground, it just takes off. I have done a hard reset, it has the latest firmware.. any ideas? I don't want to try this outside as I may end up losing the drone. Help Please... thanks
 
i have the same problem and just emailed tech support for an answer. I did try this outside and the drone almost went out of sight. It lost signal and fell like a rock. Good thing i was able to catch it.
 
I've had 4 tello drones, and 2 have occasionally shown this propensity to fly away. The first did so after a hard landing, and flew away forever. I then started printing my phone number on drones, in case they get lost, maybe I'll get back. My 3rd drone worked well for weeks, then tried a fly away - luckily I test them on my front porch, which has a roof, so if they take off and go into rapid ascent mode (when my controls are neutral and it should be hovering) they hit the ceiling preventing their escape. Interesting it is an intermittent problem - minutes later (after restarting Tello app on my iPhone XR, restarting drone, and reestablishing bluetooth with my GameSir controller), it will fly normally. If it goes into this escape mode, I can rescue it by selecting "Land" slider AND forcing hard down on hand controller. Obviously must do that before it escapes wifi range. I've had service plans, enabling me to get new drones, if I have a broken drone to take in. Obviously a big problem if it flies away -- no service plan replacement. Crutchfiied and BestBuy (Geek Squad) replacement programs will probably have their limits. I hope Tello takes this issue seriously and comes up with a firmware fix, or they may not be a company for long. Of note, Ryze tech told me iPhone XR not fully acceptable to Ryze for Tello drones, so problem may all be just my iPhone model.
 
the problem is AFAIK related to the Tello barometric sensor. You can check if the altitude displayed matches the real altitude, with takeoff point being the reference point.

The phone most likely has nothing to do with this, it's just the Ryze way to get you off the phone quickly with a simple answer.
 

Members online

No members online now.

Forum statistics

Threads
5,716
Messages
40,020
Members
17,156
Latest member
JB20