Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Tello crash - Won't turn on anymore


Apr 6, 2020
Reaction score
Hello everybody!

First of all, I tried to find someone with the same problem here in the forum and on Google, but I couldn't find it!

The crash: basic indoors crash, the Tello was on sport mode and flying backwards. It hitted the wall but nothing serious, with a 6 ft drop. No signs of damage, the battery slided a little, turning it off.

The sympthoms: It doesn't turn on anymore. I connected the charger and it started the blinking blue light until it was a solid blue, so it's charging. When I connect the charger, it also goes that cycle solid green-blinking red-blue. I did manage to do a emergency connection on it, with the following steps:

1. Charge the battery to 100%
2. Install Tello App v.1.1.1
3. Hold the Power Button on the drone WITHOUT battery in it, then connect it to a PC/Laptop USB or a charger without letting the power button, keep it holding and insert the battery in the drone, when a green led turns off release the Power button. Then a pulsing red light will start.
4. Connect the Tello drone to your phone and go to Update setting, Download the Firmware ( it will want to connect to WiFi Network with Internet, do it without turning off the drone), after downloading finished, connect with Tello again and click the Update button, wait until the end, when a Blue light starts flashing wait for another 3-4 minutes and then restart with charging cable pulled off the drone.
That's it. I hope it will help someone - DJI Tello Update Firmware Problem solved

I could do the pulsing red light thing, meaning that the power button is working. I was able to update the firmware (in case it was corrupted from suddenly turning off) but it still shows 0.0 and the battery blinks on the app as if it was none there.

So I got the following clues:
  • Battery may be ok, it charges and it's recognized as charged.
  • Power button is ok, as it can be used for commands as the pulsing red light.
  • Firmware may be ok, since it accepts commands and it shows the tello wifi when connected via the red pulsing light.
  • No external damage at all.

So, can anyone help me crack this puzzle?
PS: English is my second language, so fell free to ask if some explanation is not clear.
Last edited:

Members online

No members online now.

Forum statistics

Latest member