Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Tello: No valid imu, Python

NuclearDeveloper

New member
Joined
Sep 16, 2019
Messages
1
Reaction score
1
Hey! I have a problem, i can send these commands; "takeoff, land, emergency, battery?, speed?, time?". But when i try to move it forward or rotate it i get this error message: "No valid imu". I have calibrated it via the phone, still the same error message. Does anyone know how to fix this?
Regards Olav.
 

Attachments

  • Tello_erro.png
    Tello_erro.png
    27.2 KB · Views: 28
  • Like
Reactions: RogueSquadron1

alireza757

New member
Joined
Oct 4, 2019
Messages
1
Reaction score
1
Hey! I have a problem, i can send these commands; "takeoff, land, emergency, battery?, speed?, time?". But when i try to move it forward or rotate it i get this error message: "No valid imu". I have calibrated it via the phone, still the same error message. Does anyone know how to fix this?
Regards Olav.
I have the same problem. how can I solve it ?
 
  • Like
Reactions: RogueSquadron1

martinpi

Well-known member
Joined
Dec 15, 2019
Messages
89
Reaction score
52
Location
Vienna. Austria
Website
martinpi.at
I experienced that, too. Didi the IMU calibration which seemed to help.

This morning I got the error message again.
Next try, no error message, I was able to fly Tello in all directions using the SDK.
I don't know if it makes sense, but I got the error message when I was flying indoor with not really bright light.
 

martinpi

Well-known member
Joined
Dec 15, 2019
Messages
89
Reaction score
52
Location
Vienna. Austria
Website
martinpi.at
I experienced that, too. Didi the IMU calibration which seemed to help.

This morning I got the error message again.
Next try, no error message, I was able to fly Tello in all directions using the SDK.
I don't know if it makes sense, but I got the error message when I was flying indoor with not really bright light.
in the meantime, I can confirm that it has to do with light.

This morning started grey and foggy. I tried to do the barometer test with my new program. Tello behaved like crazy, flew against the ceiling, banged against the furniture. Luckily my wife was not at home, so I could remove the shredded leaves from her pot plants. I suspected some timing issue in my program. And the error message "no valid imu" came amidst this session.

Later, when the sun came out, everything went smoothly. Tello flew like on rails.
 

csabull96

New member
Joined
Mar 21, 2020
Messages
2
Reaction score
0
Hey everyone,

I found the solution which I already posted somewhere else:

Have a nice day!
csabull96
 

New Threads

Members online

Forum statistics

Threads
5,175
Messages
37,484
Members
14,062
Latest member
romane71193