Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

[Tello] New firmware 01.04.78.01 released!

Sage

Well-known member
Joined
Jan 13, 2019
Messages
86
Reaction score
12
Location
Miami
oh ok, what exactly does gravity calibration do? I'm hesitant to change anything because the tello is actually hoovering and flying very well...
 

umanbean

Well-known member
Joined
Nov 5, 2018
Messages
232
Reaction score
112
Location
Georgia, US
If it’s not broke don’t fix it.
Agree 100% !

I've had a phantom 3 Pro for almost 2 years. If I learned anything reading the Phantom pilot forum:

If it's flying well, do NOT upgrade firmware!... and don't bother to re-calibrate either.
 
  • Like
Reactions: volate!lo

volate!lo

Well-known member
Joined
Dec 13, 2018
Messages
1,392
Reaction score
1,233
Location
Germany
I have 4 tellos now.
Only one gets the latest firmware for testing. All others stay as they are until I find even one improvement that is worth considering an update (so far each update has made things worse).
 

volate!lo

Well-known member
Joined
Dec 13, 2018
Messages
1,392
Reaction score
1,233
Location
Germany
oh ok, what exactly does gravity calibration do? I'm hesitant to change anything because the tello is actually hoovering and flying very well...
Gravity calibration basically calibrates the motors for little changes in output power over the motor's lifetime (or changes in props due to nicks and dents, or a prop change, taking off prop guards, adding a Lego figure on top, etc).
If Tello hovers fine don't do anything. If you feel hover becomes unstable, then do the calibration.

Do never perform an IMU calibration unless you have an IMU error that persists.
 
  • Like
Reactions: Flydrone

mike357

Member
Joined
Dec 20, 2018
Messages
10
Reaction score
4
Location
Kent, UK
I just have to tell you try again to redo the two phases of calibration IMU and Gravity.
Wait for advice from more experienced users of me.
Good luck with your tello!
I recalibrated both again but no change. However... I had a lucky break😀
My iPad wouldn’t connect properly so I reset the Tello (press power for at least 5 seconds). After the reset the firmware version showed as 0.0.0.0
Which meant I was able to run the update again, after which when I flew it was behaving as well as when I first bought it.👍🏻
I’ve run 2 batteries in the same area, pleased to say no problems.
I’m so pleased to have finally solved it and got my rainy day fun back
 

umanbean

Well-known member
Joined
Nov 5, 2018
Messages
232
Reaction score
112
Location
Georgia, US
I recalibrated both again but no change. However... I had a lucky break😀
My iPad wouldn’t connect properly so I reset the Tello (press power for at least 5 seconds). After the reset the firmware version showed as 0.0.0.0
Which meant I was able to run the update again, after which when I flew it was behaving as well as when I first bought it.👍🏻
I’ve run 2 batteries in the same area, pleased to say no problems.
I’m so pleased to have finally solved it and got my rainy day fun back
Glad you got it fixed and Thanks for posting. I'll tuck that little gem back for future reference... just in case :)
 
  • Like
Reactions: Effess

Effess

New member
Joined
Jan 11, 2019
Messages
3
Reaction score
0
Guess I was wrong about recalibration solving the problem. She is now intermittently unstable, just a few times each flight, I’ve also noticed that she climbs when moving forward. See video showing instability, bit difficult to control Tello and video with phone at the same time so all video examples are showing Tello when she should be hovering. Have sent the video to Ryze support, looking forward to their response.
I'm still waiting on Ryze support... they ask me to send videos, too. Its over a couple of weeks I've now tried test flying in all the places Tello flew perfectly before... but it can't even auto land without the instability. ONE THING: Remove the prop guards it it flies more or less OK -- another user also experienced this (on the DJI forum) and reported it flew well without guards and horribly with the guards on! Wasn't the update to help it fly better WITH guards??.... hmmm. Let me know if support gives some solid answers - I will, too.

Quite upset - it was such a good little thing. As I mentioned, I was flying it - landed it - updated it - and could fly well no more... so if this isn't an update problem, it's the world's worst/best coincidence!
 

Sage

Well-known member
Joined
Jan 13, 2019
Messages
86
Reaction score
12
Location
Miami
I had the same issue with my 1st tello after updating the tello launched and became unresponsive to the onscreen sticks and continued elevating until the breeze carried it away... funny thing is I bought another tello and have not had a single problem with the update. I'm dealing with ryzerobotics through emails and they don't "seem" to want to take responsibility for the 1st tello/app update error.
 

xcrost

Well-known member
Joined
Sep 9, 2018
Messages
393
Reaction score
112
TelloFPV. Only for Android.
Ooopse?? The app shown in the pic referenced is aTello Pilot. TelloFPV is also a great app, even better in my opinion. Both are android only. There you go trying to confuse me again lol :ROFLMAO::oops::D:p:);)
 

Mike Shock

Member
Joined
Mar 13, 2019
Messages
18
Reaction score
3
Location
Russia
The most recent firmware of Tello EDU reports this Tello State string:

mid:-1;x:0;y:0;z:0;mpry:0,0,0;pitch:0;roll:0;yaw:0;vgx:0;vgy:0;vgz:0;templ:50;temph:52;tof:10;h:0;bat:100;baro:683.53;time:0;agx:7.00;agy:-8.00;agz:-998.00;
What is the meaning of the "mpry" parameter? I can't find the description in the SDK manual.
 

New Threads

Forum statistics

Threads
2,792
Messages
21,941
Members
6,742
Latest member
snaztastical