Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

[Tello] New firmware 01.04.78.01 released!

an3k

Active member
Joined
Dec 11, 2018
Messages
44
Reaction score
33
To be honest, at this point I have no clue what the flute is going on.
 

volate!lo

Well-known member
Joined
Dec 13, 2018
Messages
1,191
Reaction score
1,052
Location
Germany
They change the takeoff sequence a bit. Tello is now quicker to take off but it takes longer to transition from "starting" to "flying" state and get a reliable VPS position. I had to change the timing for the VPS position fix in TelloFPV to get a reliable fix. This might cause issues with getting a correct takeoff position for other third party apps, too.
 

raulvolador

Well-known member
Joined
Jul 19, 2018
Messages
451
Reaction score
378
Location
Spain
Yesterday I updated firmware to 01.04.78.01 version.

After update I performed a Tello reset (long press start button), an IMU calibration and Center of Gravity calibration.

All of my flight apps works ok after update (Tello official app, aTelloPilot and TelloFPV)

I only noticed a diferent Tello behaviour during takeoff. Starting motors secuence takes less time than before.

I couldn't perform any distance test to try claimed Wifi Conectivity Improvement.

all the best.
 

an3k

Active member
Joined
Dec 11, 2018
Messages
44
Reaction score
33
I got me Tello EDU today, so finally some real-life comparison!

The most recent firmware of Tello EDU reports this Tello State string:

mid:-1;x:0;y:0;z:0;mpry:0,0,0;pitch:0;roll:0;yaw:0;vgx:0;vgy:0;vgz:0;templ:50;temph:52;tof:10;h:0;bat:100;baro:683.53;time:0;agx:7.00;agy:-8.00;agz:-998.00;

The most recent firmware of the regular Tello reports this Tello State string:

mid:8;x:0;y:0;z:0;mpry:0,0,0;pitch:0;roll:0;yaw:0;vgx:0;vgy:0;vgz:0;templ:48;temph:50;tof:31;h:0;bat:100;baro:679.17;time:0;agx:-29.00;agy:-16.00;agz:-1001.00;

Based on the SDK 2.0 PDF the variable mid should be -1 if no mission pad is detected. In the above example the value is 8 which is within a valid range but I also already got a value of 257 and such. It looks like the most recent firmware of the regular Tello is buggy. I don't know if we should be able to issue mission pad related commands but as of now the regular Tello does not accept them.

However, at least both Tellos now send the same Tello State string. If your code is compatible with the regular Tello it now is also compatible with the Tello EDU <insert "it's something" or "which is nice" meme here> :)
 

an3k

Active member
Joined
Dec 11, 2018
Messages
44
Reaction score
33
Now with original Mission Pads I was able to test the regular Tello. The changelog states it now supports Mission Pads and the changed Tello State string matches that statement. However, the regular Tello does NOT recognize Mission Pads at all. It randomly changes the value of variable mid (which is the ID of the recognized mission pad) but doesn't show any pattern of when that value is changed. I then tested with my Tello EDU and did exactly the same as what I did with the regular Tello: it perfectly recognized all mission pads correctly.
 

kmostafa

Member
Joined
Dec 18, 2018
Messages
5
Reaction score
0
Ciao,
I'm having a LOT of problems with the new firmware,

- no more telemetry in Node-Red
- no video streaming with Python

luckily I have two Tello !
So I don't upgrade both....

Concerning the "new" function, I didn't find any....
Hi I am new here. I just bought the tello for the video steaming with python
Did anyone manage to solve this.Video streaming in Python.
Can you share any code for that

Thanks
 

kmostafa

Member
Joined
Dec 18, 2018
Messages
5
Reaction score
0
Ciao,
I'm having a LOT of problems with the new firmware,

- no more telemetry in Node-Red
- no video streaming with Python

luckily I have two Tello !
So I don't upgrade both....

Concerning the "new" function, I didn't find any....
Same Problem Here :( any possible resolution
 

mike357

Member
Joined
Dec 20, 2018
Messages
10
Reaction score
4
Location
Kent, UK
Updated to 01.04.78.01 firmware this afternoon. First flight she was like a completely different bird, unstable fight, controller response variable, sometimes just moving up and down a foot or so when hovering( Not in bounce mode lol)
Did reset then IMU calibration followed by centre of gravity calibration, which has resulted in nice stable flight.
One difference I have noticed is whenever I get within 6 feet from my home router there is a little instability until I move Tello away from router. I wasn’t getting this before the update, some users report better range so maybe the receiver sensitivity has been increased.
Hope to try outside tomorrow morning, with luck all will be okay 🤞🏻
 
  • Like
Reactions: DinoBaldi

Effess

New member
Joined
Jan 11, 2019
Messages
3
Reaction score
0
Updated to 01.04.78.01 firmware this afternoon. First flight she was like a completely different bird, unstable fight, controller response variable, sometimes just moving up and down a foot or so when hovering( Not in bounce mode lol)
Did reset then IMU calibration followed by centre of gravity calibration, which has resulted in nice stable flight.
One difference I have noticed is whenever I get within 6 feet from my home router there is a little instability until I move Tello away from router. I wasn’t getting this before the update, some users report better range so maybe the receiver sensitivity has been increased.
Hope to try outside tomorrow morning, with luck all will be okay 🤞🏻
I have exactly the same problem after updating to 01.04.78.01 firmware! I have been flying fine over the last 4 months (did an update along the way with no issues) and Tello was doing just great ... then I decided to do the update that was waiting. And bam - in a matter of the few minutes it took to download and install - from a stable, predictable flyer I loved to this - exactly as you mentioned "a completely different bird, unstable fight, controller response variable, sometimes just moving up and down a foot or so when hovering." I also noticed if you were about a couple of metres up it would CLIMB upwards when you were going forward, and DESCEND by itself when below a meter and going forward. Also, tap to land was hit and miss - sometimes it just bounced along the floor and did a sort of hop up again!
I did a reset, re calibrated the IMU and did the center of gravity thing - But NO... no.. no stable flight!!! Its just as iffy! I am so disappointed with Ryze ... they convert a perfect little drone to an uncontrollable monster with an update!

Another thing... if you remove the Prop guards, it flies better - no rise-fall thing.. at least not in my limited testing. But somehow even then, I feel its not as stable as before and already crashed it (or it crashed itself into the wall). Grounded Tello as of now... :cry:

Any help would be much appreciated... If anyone solved this or a way to get back to the previous firmware... I'm just a flier - no programming here. C'mon Ryze fix this!!!
 

Ferro

Well-known member
Joined
Jan 6, 2019
Messages
63
Reaction score
17
I am not experiencing any problems whatsoever. It will hover perfectly in place.
 

mike357

Member
Joined
Dec 20, 2018
Messages
10
Reaction score
4
Location
Kent, UK
Guess I was wrong about recalibration solving the problem. She is now intermittently unstable, just a few times each flight, I’ve also noticed that she climbs when moving forward. See video showing instability, bit difficult to control Tello and video with phone at the same time so all video examples are showing Tello when she should be hovering. Have sent the video to Ryze support, looking forward to their response.
 

Flydrone

Well-known member
Joined
Oct 29, 2018
Messages
226
Reaction score
102
Age
37
Location
Italy
Guess I was wrong about recalibration solving the problem. She is now intermittently unstable, just a few times each flight, I’ve also noticed that she climbs when moving forward. See video showing instability, bit difficult to control Tello and video with phone at the same time so all video examples are showing Tello when she should be hovering. Have sent the video to Ryze support, looking forward to their response.
The cello flies low over the obstacles, so it rises to altitude, try to redo the whole IMU calibration and the center of gravity.
I only say what I think ..;)
 

mike357

Member
Joined
Dec 20, 2018
Messages
10
Reaction score
4
Location
Kent, UK
The cello flies low over the obstacles, so it rises to altitude, try to redo the whole IMU calibration and the center of gravity.
I only say what I think ..;)
I edited the footage to keep it short because no one wants to watch 10 minutes of video, she was climbing and descending after a little steady hovering. It also climbs flying forward when it’s not over obstacles. Will keep trying the calibration though, could get lucky
☹
 

Flydrone

Well-known member
Joined
Oct 29, 2018
Messages
226
Reaction score
102
Age
37
Location
Italy
I edited the footage to keep it short because no one wants to watch 10 minutes of video, she was climbing and descending after a little steady hovering. It also climbs flying forward when it’s not over obstacles. Will keep trying the calibration though, could get lucky
☹
I just have to tell you try again to redo the two phases of calibration IMU and Gravity.
Wait for advice from more experienced users of me.
Good luck with your tello!
 
Last edited:
  • Like
Reactions: mike357

Sage

Well-known member
Joined
Jan 13, 2019
Messages
86
Reaction score
10
Location
Miami
How do I calibrate gravity? The app shows that option as gray not blue...
 

Flydrone

Well-known member
Joined
Oct 29, 2018
Messages
226
Reaction score
102
Age
37
Location
Italy
How do I calibrate gravity? The app shows that option as gray not blue...
the center of gravity calibration is only active when the cello is stationary in flight.
 

New Threads

Members online

Forum statistics

Threads
2,613
Messages
20,413
Members
6,232
Latest member
Brplrp