Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Tello not switching on and not charging

Leon007

Member
Joined
Aug 4, 2020
Messages
5
Reaction score
2
Hi guy's, we have now two customers that brought their Tello's back to us which have the same problem. Tello's not switching on and not charging. We have tried all the reset functions we could find on the internet and on the manual.

Is there a way one can update the firmware without the craft being switched on? (plug into computer maybe) to do the update? And where do one get the firmware?
 

r0ckf1re

Active member
Joined
Dec 3, 2018
Messages
25
Reaction score
2
Hi guy's, we have now two customers that brought their Tello's back to us which have the same problem. Tello's not switching on and not charging. We have tried all the reset functions we could find on the internet and on the manual.

Is there a way one can update the firmware without the craft being switched on? (plug into computer maybe) to do the update? And where do one get the firmware?

Remove the battery, hold down the power button as you slide the battery in.

Firmware is updated via the Tello app

Sent from my iPhone using Tapatalk
 

Leon007

Member
Joined
Aug 4, 2020
Messages
5
Reaction score
2
Remove the battery, hold down the power button as you slide the battery in.

Firmware is updated via the Tello app

Sent from my iPhone using Tapatalk
Thank you, I have done that a couple of times also on both crafts, still nothing. The one craft green light stays on the whole time, even if I do a reset (press on button for 5 sec). The other craft blink red a couple times, then goes off, then nothing happens there also. (no charging not switching on, nothing at all)
 

r0ckf1re

Active member
Joined
Dec 3, 2018
Messages
25
Reaction score
2
Thank you, I have done that a couple of times also on both crafts, still nothing. The one craft green light stays on the whole time, even if I do a reset (press on button for 5 sec). The other craft blink red a couple times, then goes off, then nothing happens there also. (no charging not switching on, nothing at all)

How old are the batteries ? Mine had issues. Replaced the battery and it’s fine now.


Sent from my iPhone using Tapatalk
 

Leon007

Member
Joined
Aug 4, 2020
Messages
5
Reaction score
2
How old are the batteries ? Mine had issues. Replaced the battery and it’s fine now.


Sent from my iPhone using Tapatalk
Yes, maybe I'll have to try all my other batteries I still have. We are dealers and already tried three new batteries. Thanks for your reply I appreciate your help
 
  • Like
Reactions: r0ckf1re

Thundre1

New member
Joined
Sep 17, 2019
Messages
4
Reaction score
3
Just a thought: Can you bypass the battery by connecting a power supply directly? Maybe either the Tello battery connectors or where the battery attaches to the main board will get you running
 

Flydrone

Well-known member
Joined
Oct 29, 2018
Messages
718
Reaction score
442
Location
Italy
try to charge the batteries with an external charger and try again ...
for a restore try this system.


1. Delete Tello's app and reinstall it. 2. Forget Tello's wifi on your mobile.
3. Reset its WIFI: Turn the TELLO on until its flashing yellow rapidly, then press and hold the power button for 5-8s until the led goes off, then reconnect after it auto rebooting.
 

Leon007

Member
Joined
Aug 4, 2020
Messages
5
Reaction score
2
try to charge the batteries with an external charger and try again ...
for a restore try this system.


1. Delete Tello's app and reinstall it. 2. Forget Tello's wifi on your mobile.
3. Reset its WIFI: Turn the TELLO on until its flashing yellow rapidly, then press and hold the power button for 5-8s until the led goes off, then reconnect after it auto rebooting.
HI Flydrone
Thanks but my problem is not connecting. The problem is the drones do not switch on as they suppose to.
I charged all batteries now with the charging hub, all charge fully. I tested them also on another brand new drone earlier and it worked perfectly.
I ran out of options now, these two drones just do not want to switch on correctly. The one blink red the whole time and the other one just stays on green, no matter what I do. 🤷🏻‍♂️
 

agraham

Well-known member
Joined
Jul 10, 2020
Messages
52
Reaction score
13
Looks like they are broken. Can't you return them to your wholesaler?
 

Leon007

Member
Joined
Aug 4, 2020
Messages
5
Reaction score
2
Looks like they are broken. Can't you return them to your wholesaler?
Hey agrham
Yes I'll probably send them back and let them sort it out/replace them.
The thing is, things are so bad in SA these day's even our wholesalers are battling to keep everybody happy because sending stuff back to China for them to fix it takes months. For us as retailers we need to give proper customer service if we want to build a good relationship and want to grow.
 
  • Like
Reactions: agraham

Flydrone

Well-known member
Joined
Oct 29, 2018
Messages
718
Reaction score
442
Location
Italy
HI Flydrone
Thanks but my problem is not connecting. The problem is the drones do not switch on as they suppose to.
I charged all batteries now with the charging hub, all charge fully. I tested them also on another brand new drone earlier and it worked perfectly.
I ran out of options now, these two drones just do not want to switch on correctly. The one blink red the whole time and the other one just stays on green, no matter what I do. 🤷🏻‍♂️

Forgive me, I understand what you mean.
I believe the ACT8846 chip could be responsible for power management ...
You should try replacing it to see if it fixes the problem, but it could be elsewhere!
This is only my hypothesis and I could be wrong.

You could try reflowing the chip with hot air.

this is a fairly complicated job if you are not capable and also need some equipment.

See attached datasheet
IMG_20181221_185651.jpg
 

Attachments

  • ACT8846_Datasheet.pdf
    2.6 MB · Views: 4
Last edited:

New Threads

Members online

No members online now.

Forum statistics

Threads
5,064
Messages
36,657
Members
13,612
Latest member
BaBaBommel