Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Tello Problem - Newbie

JMDinFlorida

New member
Joined
Dec 6, 2022
Messages
3
Reaction score
1
Location
Florida
Hi all - I'm new to the forum and Tello
Recently bought a used Tello, without battery. I purchased a fullymax from B&H.
Battery cam in with a charge of 2.75 volts.
Question # 1 - Is this battery ruined forever?
There are a lot of battery issues on this forum.
Question # 2 - Does battery quality pose a problem to many Tello owners?
First turn on - green lite for ~5 sec then 4 or 5 red flashes - then nothing. Will repeat if batt is removed, reinserted
Tello initially would not charge the battery. I rigged an external charger- brought battery to 4.2 V.
With OEM battery, Tello will not turn on before or after charging - no change after charging.
Following some info on this forum - I plugged into PC via USB while holding down on/off button.
Attempted to upgrade firmware - fails on last step, when sending firmware to drone 'an error has occurred'.
Any suggestions?
- Did I get a bad drone?
- Did I get a bad battery?
- Is it appropriate to try to upgrade firmware? filed with both apple and android app
- Try a new battery?

Please comment
JMD
 

Hacky

Well-known member
Joined
Jul 19, 2021
Messages
282
Reaction score
116
Location
Germany
A LiPo battery that comes from stock with 2.75V cell voltage will most probably be harmed already and I would not expect full capacity anymore.

If you brought the battery back to 4.2V, Tello should be able to be activated - even with an outdated firmware. What kind of firmware update did you proceed? I do not know a procedure with PC connection. Standard procedure is update via Tello app. There are several threads hier adressing problems with firmware update.
 

Dan

Well-known member
Joined
Feb 20, 2020
Messages
210
Reaction score
75
Hello. Flying drones is not a cheap hobby. be prepared to spend some money on batteries. Buy a least three from a good source!! This is an eternal battle with micro drones. We have a fleet of Tellos. We have worked with a Chinese micro drone company and were recently requested to test over 300 micro drone batteries stocked in a USA warehouse for two years. they were all good But were with us for over a year before they were shipped back because of duty issues and battery shipping,. We sent them on, and i presumed they were sold. Sometimes you can find a date on them. Good luck
 

JMDinFlorida

New member
Joined
Dec 6, 2022
Messages
3
Reaction score
1
Location
Florida
Thanks for your replies

Hacky - poor wording on my part. I was updating through the phone app - I tried both iOS and Android. Both failed the same way.
(One technique that I found for entering update mode required connecting USB cable to PC while holding on/off button, with battery removed)
Using the app, I downloaded the update from internet to phone, then switch to Tello wi-fi to send update to Tello.
Update downloads correctly to phone , but when sending from phone to Tello - message says ' an error has occurred, restart app to retry.

Dan - Battery is a FULLYMAX (OEM I believe), date is 2022-07-29. Seems like it should be good.

Any significance to the flashes on button press? 5 sec green, five red flashes then off.

Thanks
JMD
 

JMDinFlorida

New member
Joined
Dec 6, 2022
Messages
3
Reaction score
1
Location
Florida
Tello fans
A quick follow up on the problem I was facing.
On the possibility that my problem was just poor electrical connections -
I removed the top cover - in my case the white cover with TELLO printed on it.
I carefully forced a pencil tip between the gold colored battery contacts on the drone. (I did nothing to the battery)
Not a lot of force - just pushing each contact lightly away from vertical in the hopes of causing better contact between battery and drone contacts.
I then inserted the battery and pushed the on button. The drone then behaved normally - some flashing ... yellow flashing.
After connecting to tello wifi - I get a video stream to phone and a responsive Tello.

Still have problems - on take off drone flips to a corner - maybe a bad motor. I will dig in further.
I have no idea how common this problem is - but it might be worth a try if your Tello seems dead.

JD
 
  • Like
Reactions: volate!lo

New Threads

Members online

No members online now.

Forum statistics

Threads
5,504
Messages
39,115
Members
15,888
Latest member
Doro