Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Tello state Zero Values

Icarus0408

Member
Joined
Oct 27, 2020
Messages
6
Reaction score
0
Hi was just wonder why my tello edu shows 0 at velocity data part. Im moving my drone picking it from the top but the velocities keeps saying zero while like accelerometer are getting readings

Any ides why its showing this?
trying to use the data from tello state to get the distance of the drone moved
 

robagar

Member
Joined
Apr 17, 2021
Messages
23
Reaction score
11
Maybe the velocity is inferred from movement commands sent, rather than measured like accceleration? The drone IMU hardware can detect acceleration, but not velocity
 
  • Like
Reactions: pgminin

Icarus0408

Member
Joined
Oct 27, 2020
Messages
6
Reaction score
0
Maybe the velocity is inferred from movement commands sent, rather than measured like accceleration? The drone IMU hardware can detect acceleration, but not velocity
i just tried it, still 0 vx,vy,vg. even while moving with the drone in the air
 

Rom13IL

Member
Joined
Dec 21, 2020
Messages
7
Reaction score
1
Hi was just wonder why my tello edu shows 0 at velocity data part. Im moving my drone picking it from the top but the velocities keeps saying zero while like accelerometer are getting readings

Any ides why its showing this?
trying to use the data from tello state to get the distance of the drone moved
I don't remember exactly about the velcoity data but I do know there are problems in the stauts port. I always saved the recent sent velocity values so i didn't need to use that but for example when I did take offs i wanted to check the height so the drone will be around the same height as my face to preform face recognition but the Height value on the second flight was always 0 every tho it reached the roof so... might be a similar case ^_^
 

New Threads

Members online

No members online now.

Forum statistics

Threads
5,064
Messages
36,657
Members
13,617
Latest member
Wazidtello