Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Works with Samsung S8 and then stops connecting

MilesAB

Member
Joined
Jun 5, 2018
Messages
5
Reaction score
2
so I had a few days where the Tello connected to my S8 and worked well. then today I took the Tello to the beach to take some videos with the family. I ended up spending 1.5 hours rebooting, reinstalling etc. and the tello would not connect.

So the Tello wifi appears and I connect with my phone. However the Tello app reports it isn't connected. Tried wifi reset on trello, tried uninstalling trello app and reinstalling, tried rebooting phone etc. Nothing worked.

I came back home and contacted support. They said the S8 isn't supported. Now the S8 has been out over a year and has already been superseded by the S9. So they only support older phone such as S7 and S6 etc. Support asked me if i had an ipad. Yes, and iPad pro. Then told by support it wasn't supported!! This is about 2 years old. So no new models supported only older models.

Anyway, support helpfully told me to wait until the new firmware comes out that supports the S8. I asked how I could install this firmware if I can't connect. No answer from support.

So question is why my phone did work and now doesn't work. not sure what changed and support can't help. I have a Tello drone I can't use and most probably can't update with the latest firmware. Anybody else managed to fix this?
 

MilesAB

Member
Joined
Jun 5, 2018
Messages
5
Reaction score
2
It worked! I don't understand why turning off mobile data allows the Tello app to connect but it does work. Connects well and flies without an issue. I would not have tried this unless you had suggested it. Thank you. I hope they fix this in a firmware update.
 

New Threads

Members online

Forum statistics

Threads
3,432
Messages
26,638
Members
8,906
Latest member
clollett