Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Controller stopped working

Hydrostan

Well-known member
Joined
Dec 24, 2019
Messages
52
Reaction score
37
I use a Gamesir T1s and Tello FPV. Up to today I would plug in my OTG cable, the 'A' for Android light would come on steady, and I was in business. Now, all the "mode indicator" lights flash on and off and I have no connection. I tried connecting with the Tello App and it will only connect via Bluetooth. Using Tello FPV I can't connect at all. Any thoughts on how to rectify this problem?
 

volate!lo

Well-known member
Joined
Dec 13, 2018
Messages
2,779
Reaction score
2,579
Location
Germany
No clue.

Just a hint when looking for solutions to such problems:
This isn't a specific TelloFpv or Tello type of problem but a T1S problem. You have much better chances to find a solution if you look for solutions in the internet not mentioning the Tello at all. So never search for anything like "Tello t1s" or so because you limit your searches to those few users that are actually using this controller for Tello.
 
  • Like
Reactions: Terry

xcrost

Well-known member
Joined
Sep 9, 2018
Messages
487
Reaction score
188
I would guess the cable is bad. The one that came with my T1s failed in first few months. Good luck!
 

Hydrostan

Well-known member
Joined
Dec 24, 2019
Messages
52
Reaction score
37
No clue.

Just a hint when looking for solutions to such problems:
This isn't a specific TelloFpv or Tello type of problem but a T1S problem. You have much better chances to find a solution if you look for solutions in the internet not mentioning the Tello at all. So never search for anything like "Tello t1s" or so because you limit your searches to those few users that are actually using this controller for Tello.
You are correct. I did a lot of searching on the web and "sort of" got it working. I say sort of as different lights come on now then before, but at least I can fly my tello again with that controller. I could boot myself in the rear for not returning the controller after I purchased it as it did weird things from the beginning.
 

AnGo

Well-known member
Joined
Jun 19, 2019
Messages
102
Reaction score
61
The Gamesir T1s also seems no longer to be available - at least not over Amazon in Germany where I bought mine about half a year ago.

I also had this blinking issue at the beginning with mine. It turned out that I had to press a certain combination of buttons to fix that.

I started a thread these days on this topic, too, where the solution was provided that worked for me:

Since then I had no more issues as long as I power up the controller BEFORE connecting the phone to it. If I connect the phone first and then power up the controller, it sometimes also starts blinking again and then I never get it connected.
 
  • Like
Reactions: Hydrostan

Hydrostan

Well-known member
Joined
Dec 24, 2019
Messages
52
Reaction score
37
Thanks for all for the suggestions on correcting this problem. It was interesting to see the 2 keypad LEDs on in the photo of the controller. When I first got the T1s functioning, I had both the Android and mouse simulation LEDS on, and the controller worked okay with the drone. After awhile I suddenly only got the androidLED and again all was well. After doing the resetting, I again have both android and mouse LEDs, and once again it is working.

Reading these posts I see where there surely are problems with the T1s, but like others I purchased the T1s and not the T1d because it gives you the option to use the OTG cable and not possibly get video interference using a Bluetooth connection.
 
  • Like
Reactions: xcrost

Members online

Forum statistics

Threads
5,069
Messages
36,673
Members
13,626
Latest member
Jelliott4x4