Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

DJI Tello programming with Scratch | No Valid IMU

tomwilhelm

New member
Joined
Jan 10, 2020
Messages
2
Reaction score
1
Hi

I bought some Tello drones. The reason why I choose the Tello drone was the feature that you can programm it with Scratch. Unfortunately I cannot programm the Tello with Scratch. Only several flight commands are working. The commands flip and takeoff are working for example but the fly forward will not get executed. In the terminal it shows no valid imu if I try to fly forward for example.

I already tried to recalibrate the imu and update the firmware on the tello. This unfortunately didnt worked. Then I thought its a hardware problem but this isn't the case because the Tello is flying flawlessly with the iPhone app. I also tried it on other notebooks and on another Tello. Always the same error. On the web I have found some other posts of people with the same problem. Unluckily no one had a solution. Here are two posts of other pilots who reported the same issue:

- No valid IMU
- Tello: No valid imu, Python

After that I tried to contact the support of Ryzerobotics. But their Phone and SDK Support is useless. They just told me to recalibrate the imu and upgrade the firmware. I already told them that I tried this multiple times. After that, I got ignored for a Month. I called them and they told me I should just resend the Mail. Which I did and they came again with <<please upgrade the firmware and calibrate the IMU>> even if I wrote them in the Mail that I have tried this multiple times. Now I am just getting ignored.

I am really upset because I now have 6 Tellos which are useless for me.

Can somebody from the Community help?

(sorry for my bad english)

Kind regards,
tomwilhelm
 

FriwiDev

Member
Joined
Dec 26, 2019
Messages
16
Reaction score
7
I stumbled upon this error when developing my library. Your tello drone uses a camera to capture the ground below your drone and calculate the distance moved by comparing the frames. Your drone can only tell how far it flew forward if the ground below provides enough textual details. If it does not, your tello will not perform the command, responding with "error No valid IMU". Sadly, the sdk does not mention error messages and their reason. To fix the "No valid IMU" error, put some tape on the ground (make the mesh wide enough), or fly over differently colored materials.

Tip: When the battery is too low to perform a command, your drone will simply answer with "error" (without a reason). This is also mentioned nowhere.
 
  • Like
Reactions: Kyle Knox

Members online

No members online now.

Forum statistics

Threads
5,069
Messages
36,676
Members
13,627
Latest member
vertex17