Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Error code 203

Joined
May 5, 2018
Messages
6
Likes
3
#1
Hi forum, anyone facing an issue with error code 203. I just got the tello 4 days back. Post firmware update am constantly getting error code 203. The weird part is when i cool the battery down from rrom temperature it starts working. Anyone has ideas how to revert to the old firmware. Thanks
 
Joined
May 5, 2018
Messages
6
Likes
3
#5
Well i finally gave up on this unit. Thumbs up to ryze for the support they are quite responsive. Seems there was an issue with the battery and it wouldnt work. Returned mine. Contemplaring getting another as it sure is fun for flying around the house.
 

clexa

New member
Joined
May 27, 2018
Messages
3
Likes
0
#6
I have the same error 203. Did you resolve yours?
Im on IOS, it flew fine out of the box, then i updated the firmware and couldnt fly anymore from then on. Restarted, reinstalled apps, recalibrated, removed battery, reinserted, nothing works.
 
Joined
May 5, 2018
Messages
6
Likes
3
#7
Hi error 203 is an issue with the battery i doubt if it can be resolved . I gave mine back as ryze support was taking a long time and it was highly unlikely they would be able to resolve it.
 

Puxa-tello

New member
Joined
Jul 5, 2018
Messages
2
Likes
1
#8
I am so sorry but I cant understand how can u resolve this problem... anyone can explain it?
 
Last edited:

DavidDH

New member
Joined
Jul 20, 2018
Messages
3
Likes
0
Location
Kuwait
#9
Ryze support say to leave battery to cool for 30 minutes
Does this work or do I need to get replacement battery?
 

DavidDH

New member
Joined
Jul 20, 2018
Messages
3
Likes
0
Location
Kuwait
#10
After talking again to support it seems that in some cases the update fries the battery and only option is for a warranty replacement
 

ecmo

New member
Joined
Aug 20, 2018
Messages
1
Likes
0
#11
I have the same problem after update,
are there others options than battery replacement ?
 

Phear8me

New member
Joined
Sep 24, 2018
Messages
1
Likes
0
#13
Got same problem today

New tello used less than a handful of times

Set it up today and required a update now can't use it all 3 batteries same error
 

Palletus

New member
Joined
Dec 22, 2018
Messages
3
Likes
0
#14
Got same problem today

New tello used less than a handful of times

Set it up today and required a update now can't use it all 3 batteries same error
Same here. After lots of troubleshooting with resetting drone, reinstalling software and firmware end result is to return unit. I can understand reasons for allowing only authorized batteries, but these kind of things can produce angry customers if functionality is not tested properly.
 

Flydrone

Well-known member
Joined
Oct 29, 2018
Messages
95
Likes
39
Location
Italy
#15
try to hold down the power button of the drone without a battery, then always holding down the button insert the battery.
 

Flydrone

Well-known member
Joined
Oct 29, 2018
Messages
95
Likes
39
Location
Italy
#17
try to reset by keeping the power button pressed for 10 seconds. with the battery inserted

greetings and merry christmas.
 

bmelody

Active member
Joined
Oct 18, 2018
Messages
26
Likes
8
#18
I too have an error 203 on 3 different batteries. All my batteries are OEM. All were working just fine, then after recharging all 3 show error 203. I have tried all the mentioned fixes but no luck. I purchased the unit back in Oct 2018 so I am still under warranty. I have been in contact with Ryze support by email (slow process) but no RMA yet. I did get it via Amazon and may attempt a replacement through them. I was running the original firmware when the error occurred. I downloaded the latest firmware update but still no help.

Has anyone found any other way to repair this error?
 

bmelody

Active member
Joined
Oct 18, 2018
Messages
26
Likes
8
#20
I agree it is a brick in its current condition. It is just so much fun to fly around inside the house. I have a Spark a Mavic Pro and 2 Phantom 3's but they are not really good for indoors. I would fly the Tello almost every day. I did put the prop guards on the Spark yesterday and flew it in the house but it is very noisy compared to the Tello. I hope I can get a warranty repair or replacement. soon
 

New Threads

Forum statistics

Threads
2,181
Messages
15,649
Members
5,248
Latest member
Beard Beardington