Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Live feed not working for camers

Tgdone1

New member
Joined
Dec 26, 2018
Messages
2
Reaction score
0
Location
Ohio
I just got my Tello and the video/camera feed is all static (see screenshot). When I snap a photo it comes out just fine. Any solution? Thanks!Screenshot_20181226-184933.png
 
I had the exact save results using the OEM Tello app on my Note 9. I believe it is an issue with how Samsung interprets the photo graphics from the app. Firmware updates, power cycle and clearing memory had no effect. However, I switched to the new TelloFPV app and had no problems.
 
  • Like
Reactions: TelloPilot2019
Thanks for the feedback. I'm using a motox4. I am using the official Tello app (see attached). All the firmware is updated and I'm still getting the green static screen instead of the live feed from the drone. Do I need to return the drone?
 

Attachments

  • Screenshot_20181227-143536.png
    Screenshot_20181227-143536.png
    128.6 KB · Views: 16
Do I need to return the drone?

No. It's probably just some misunderstanding between codecs in Tello app and your system. I have similar results with one of my devices (switching to video mode makes live view visible, though in grayscale), but two others work flawlessy. Try some other app -- what we have is aTello (free, quite simple but has everything needed to fly), aTello Pilot (paid, very good app) and TelloFPV (paid with free demo, very good app too, and under very active development); I bet the other apps won't show the problem.
 
Ok, guess I'm not alone. Just got a Note 9. The Tello app works fine on my old phone (Droid Turbo), no video on the Note 9. However, the Tello FPV app does video just fine, as somewhat noted above.

Why the switch? The Droid's screen is impossible to see when the sun is out.
 
No. It's probably just some misunderstanding between codecs in Tello app and your system. I have similar results with one of my devices (switching to video mode makes live view visible, though in grayscale), but two others work flawlessy. Try some other app -- what we have is aTello (free, quite simple but has everything needed to fly), aTello Pilot (paid, very good app) and TelloFPV (paid with free demo, very good app too, and under very active development); I bet the other apps won't show the problem.
Clearly some Codec trouble.

I can recommend you try aTelloPilot and/or TelloFpv. We all owe Krag a lot for his early efforts and development of aTello but its a fact that aTello never really made it to anything more than concept level.


Or you can try to mess around with the Android developer settings for GPU rendering, hardware acceleration, etc. Please ask Mr. Google for details. I won't give details for this as playing with these settings can cause a lot of trouble.
 
Thanks very much for the tips :). Got my first drone yesterday.

Want to use a drone high up in the mountains on longer hiking trips, but having no experience at all in drone flying I decided to learn first, and for that purpose bought the Tello.
But with my Moto G5plus the Tello App did'nt show live feed at camera, and at film mode the recording was blurred. With a Fairphone it worked fine.

With the Tello FPV app (the demo) also my Moto phone seems to be working properly.

Still tons of questions, but I'll first check out this forum. It's lots of fun (I have 3 batteries), and crashed only 6 times up to now ;). Some steering to learn. The Tello can take a lot.

Joop
 
Last edited:
With the Tello FPV app (the demo) also my Moto phone seems to be working properly.

Scratch up five bucks, pay for TelloFpv, forget the others... that's what I did.

TelloFpv raised the Tello experience to new levels - finally the capabilities of a Tello flight app closely match the capabilities of the hardware.

Enjoy!
 
Thanks for the feedback. I'm using a motox4. I am using the official Tello app (see attached). All the firmware is updated and I'm still getting the green static screen instead of the live feed from the drone. Do I need to return the drone?


Have you tried using the tello fpv google app
 
Continued to my last post and question...i downloaded tello fpv app and the camera works ok....then when i switch to tello app....camera doesnt work....i am using asus rog phone 2 with android 9.what to do?any help will be appreciated.
 
Continued to my last post and question...i downloaded tello fpv app and the camera works ok....then when i switch to tello app....camera doesnt work....i am using asus rog phone 2 with android 9.what to do?any help will be appreciated.
So what's the problem? Forget the OEM Tello app, use Tellofpv it's MUCH better anyway.

The OEM Tello app is not going to work on your phone.

By the way, without searching for it, no one knows what 'last post' you're speaking of
 
Continued to my last post and question...i downloaded tello fpv app and the camera works ok....then when i switch to tello app....camera doesnt work....i am using asus rog phone 2 with android 9.what to do?any help will be appreciated.
Codec issues. Only way to fix is to use a 3rd party app.

or you can complain at Ryze, just like thousands have done before. Their suggested fix: buy a new phone.
 
Thanks very much for the tips :). Got my first drone yesterday.

Want to use a drone high up in the mountains on longer hiking trips, but having no experience at all in drone flying I decided to learn first, and for that purpose bought the Tello.
But with my Moto G5plus the Tello App did'nt show live feed at camera, and at film mode the recording was blurred. With a Fairphone it worked fine.

With the Tello FPV app (the demo) also my Moto phone seems to be working properly.

Still tons of questions, but I'll first check out this forum. It's lots of fun (I have 3 batteries), and crashed only 6 times up to now ;). Some steering to learn. The Tello can take a lot.

Joop
Did you use a fairphone 2?
 
Hello everybody,
I just got the same video problem on a Motorola G6. Tello FPV fixed it right away!
(I did send back the 1st drone, thinking that the drone had a problem, but the new one had the same symptoms).

I also tried on my chromebook (Lenovo Duet 1st gen), but it seems that the application hangs :( (both apps, original and FPV).

I will continue on my chromebook using python and port forwarding to linux. I hope this will work as I initially intended to dev computer vision apps with the tello drone on my chromebook initially.

Christophe.
 
Chromebooks is a special breed as Google changed something in the networking that makes them incompatible with my apps.
 

Members online

No members online now.

Forum statistics

Threads
5,699
Messages
39,965
Members
17,059
Latest member
erde