Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Start / altitude failure

thymjan

New member
Joined
Jul 10, 2018
Messages
4
Reaction score
0
After a crash with a tree my tello seems to have problems in getting the right altitude measurement. After starting the drone it doesn‘t hover in the air like before. It goes down immediately while the altimeter rises up several meters (up to 3 or 4 meters). It touches ground without stopping the motors and sometimes the altimeter gets negative values then (like -7 meters). I can use the controls like before, the video transmission is working fine. But the drone acts like it has to carry a heavy stone.

At some “fresh” starts it works like before then suddenly switches to the “heavy stone mode”. Or if I switch to sports mode I can lift the drone slowly then suddenly it goes up like a rocket and immediately falls down like a stone.

Maybe a temperature problem? Or a loose connection of the barometer?
Does anybody did experience such problems before?
 

xcrost

Well-known member
Joined
Sep 9, 2018
Messages
413
Reaction score
123
Try new props. Also you may have motor going bad.
 

thymjan

New member
Joined
Jul 10, 2018
Messages
4
Reaction score
0
I’ve attached new propellers. This can’t be the reason.

How do you detect a motor goes defective? If a motor needs more current than before due to short circuit and this let the controller goes to hot. This might be a reason.
But how can one detect this at the tello?

And why isn’t the altitude then correct anymore? Because of the maximal current drain to the motors?
 

volate!lo

Well-known member
Joined
Dec 13, 2018
Messages
1,714
Reaction score
1,626
Location
Germany
try to clean the bottom VPS camera (pinhole between the 2 big IR eyes)
 

Ansia

Well-known member
Joined
Oct 14, 2018
Messages
1,030
Reaction score
389
Do an IMU and Gravity calibration. Most likely the barometer will correct itself after IMU, the going up and down will fix after gravity.
 

thymjan

New member
Joined
Jul 10, 2018
Messages
4
Reaction score
0
I did IMU calibration several times with no success. But can this be the solution when the drone at first attempt behaves normal and after 2 minutes goes to the heavy stone mode?

Can you explain how you do the gravity calibration?
 

New Threads

Members online

No members online now.

Forum statistics

Threads
3,230
Messages
24,981
Members
8,325
Latest member
odtech