Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Tello Blinks Slow First and then Fast and repeats this while charging

Djay7026

Member
Joined
Mar 12, 2019
Messages
6
Reaction score
1
I got my Tello, a couple of months ago. I used it for about a month and then stored it away, in the box that it came in, in my cupboard. Took it out today, didn't turn on, no lights(as expected), but when I put it for charging, the led indicator first blinks blue slowly and then relatively faster and then goes back to slow blinking and this repeats. Put it for charging for about 2 Hours now and the drone doesn't turn on at all when the power button is pressed firmly(no lights at all). Please help me, I really like the Tello and I don't think I'll be able to buy a new one
 

etkaveman24

New member
Joined
Feb 16, 2019
Messages
3
Reaction score
1
What is the amperage output of the power supply you are using? It must be at least 2.1 amps to get a full charge on the batteries.
 

Djay7026

Member
Joined
Mar 12, 2019
Messages
6
Reaction score
1
Thanks for the reply !!!
The power rating on my adapter is 1.5A. Seems like this isn't enough. Will have to get a new one and try. Will update once that is done.
 

ronaldsteven

New member
Joined
Jul 11, 2019
Messages
2
Reaction score
0
Tengo problemas para encender mi tello.

Tengo las 3 baterías cargadas, pero cuando las conectas al tello y las enciendes. Primero aparecen las luces verdes y después de 5 segundos parpadea suavemente en rojo.
 

Djay7026

Member
Joined
Mar 12, 2019
Messages
6
Reaction score
1
Tengo problemas para encender mi tello.

Tengo las 3 baterías cargadas, pero cuando las conectas al tello y las enciendes. Primero aparecen las luces verdes y después de 5 segundos parpadea suavemente en rojo.
Tello hace esto cuando la batería no está correctamente conectada al tello. Puede haber algún problema con la conexión de la batería
 

New Threads

Members online

Forum statistics

Threads
3,345
Messages
26,020
Members
8,641
Latest member
atoro