Hello Tello Pilot!
Join our DJI Tello community & remove this banner.
Sign up

Won't take off

umanbean

Well-known member
Joined
Nov 5, 2018
Messages
453
Reaction score
255
Age
64
Location
Georgia, US
It just revs up flys a bit then stops. Sometimes it flips to the left and some time revs up hard and climbs uncontrollably. Now just doing a quick jump then stopping as described above.
Sounds like it might be an issue with one or more motors, have you checked them?
  • 'Flick' each prop with your finger and see if they all turn freely, and spin for the same amount of time.
  • Start the motors with a CSC (pull both sticks down and to the inside), then shut it down with left stick all the way straight down. Watch the props closely to see if one stops before the others.
  • Since you say it sometimes flips to the left pay special attention to the two motors on that side
 
  • Like
Reactions: ZWActual

bcossart

Member
Joined
Sep 16, 2019
Messages
12
Reaction score
0
Thanks for the email umanbean. I checked the motors, they all spin freely and seem to run the same. They all stopped at exactly the same time after a CSC start...
 

bcossart

Member
Joined
Sep 16, 2019
Messages
12
Reaction score
0
When I start with CSC it runs nice and smoothly until I use the throttle, then it starts to behave erratically.
 

umanbean

Well-known member
Joined
Nov 5, 2018
Messages
453
Reaction score
255
Age
64
Location
Georgia, US
When I start with CSC it runs nice and smoothly until I use the throttle, then it starts to behave erratically.
Are you using a controller?
If yes, have you tried flying without it?
Have you inspected/cleaned the bottom facing camera and IR sensor and emitter?

Would you be comfortable taking the bottom cover off and inspecting the circuit board for possible broken or cold solder joints?

Maybe @ZWActual will pop in shortly. He always has fresh ideas and suggestions.

Good luck
 
  • Like
Reactions: Yo-dude

Yo-dude

Well-known member
Joined
Mar 19, 2018
Messages
137
Reaction score
43
I was going to ask about the props... So... was it flying okay before?
 

Yo-dude

Well-known member
Joined
Mar 19, 2018
Messages
137
Reaction score
43
Are you using a controller?
If yes, have you tried flying without it?
Have you inspected/cleaned the bottom facing camera and IR sensor and emitter?

Would you be comfortable taking the bottom cover off and inspecting the circuit board for possible broken or cold solder joints?

Maybe @ZWActual will pop in shortly. He always has fresh ideas and suggestions.

Good luck

Good point... but seems to be happening to others as well...
 
  • Like
Reactions: umanbean

ZWActual

Well-known member
Joined
Jul 8, 2019
Messages
384
Reaction score
204
Location
Witless Protection
@bcossart

Can you clarify:
  1. Were you flying indoors or outdoors? What was the lighting conditions?
  2. Was the Tello involved in a crash prior to this issue? On a specific motor?
  3. "it flips to the left" - flipped on the horizontal axis on its own?
  4. One (or more) motors hotter than the other? Use a IR temperature gun (as it may be too hot to touch).
  5. What rev is the firmware? App version?
To add to @umanbean's VPS steps:
  • With the Tello upside-down, is the right rear IR emitter faintly lit red, visually?
  • Using a (cellphone) camera, point it to the IR emitter. It should glow a faint purple and pulsating.
The IMU calibration was done:
  • On a flat, level surface on all axis?
  • No movement/vibrations when calibrating?
  • Prop guards/propellers off when calibrating (optional)?
  • Tello was properly cooled down and calibrated in room temperature (or lower temps)?
Am assuming you're using the stock Ryze Tello app, have you tried (not sure what device you're using (Android or iOS)):
  • Clearing the app's cache/storage
  • Uninstalling/reinstalling the app
  • Resetting the Tello's Wi-Fi connection
  • Flying in Airplane mode
  • Using a hardline OTG connection to a controller rather than Bluetooth
  • Flying with @volate!lo's TelloFPV demo/full app?
Short of that, it may be a FC/ESC issue. Are you still within the warranty period?
 
Last edited:
  • Like
Reactions: umanbean

bcossart

Member
Joined
Sep 16, 2019
Messages
12
Reaction score
0
Good point... but seems to be happening to others as well...
Flying with our without controller gives the same result. I will clean the sensors, haven't tried that. Yep I could take the bottom off and look for cracks.
 

bcossart

Member
Joined
Sep 16, 2019
Messages
12
Reaction score
0
@bcossart

Can you clarify:
  1. Were you flying indoors or outdoors? What was the lighting conditions?
  2. Was the Tello involved in a crash prior to this issue? On a specific motor?
  3. "it flips to the left" - flipped on the horizontal axis on its own?
  4. One (or more) motors hotter than the other? Use a IR temperature gun (as it may be too hot to touch).
  5. What rev is the firmware? App version?
To add to @umanbean's VPS steps:
  • With the Tello upside-down, is the right rear IR emitter faintly lit red, visually?
  • Using a (cellphone) camera, point it to the IR emitter. It should glow a faint purple and pulsating.
The IMU calibration was done:
  • On a flat, level surface on all axis?
  • No movement/vibrations when calibrating?
  • Prop guards/propellers off when calibrating (optional)?
  • Tello was properly cooled down and calibrated in room temperature (or lower temps)?
Am assuming you're using the stock Ryze Tello app, have you tried (not sure what device you're using (Android or iOS)):
  • Clearing the app's cache/storage
  • Uninstalling/reinstalling the app
  • Resetting the Tello's Wi-Fi connection
  • Flying in Airplane mode
  • Using a hardline OTG connection to a controller rather than Bluetooth
  • Flying with @volate!lo's TelloFPV demo/full app?
Short of that, it may be a FC/ESC issue. Are you still within the warranty period?
1. I was flying outside about 11am, bright conditions no wind, had flown it here many times under same conditions.
2.I had been away for two months without the Tello. When I got home I went for a fly :) On first flight the Tello drifted and would not hold position. I thought that was strange but flew it for a few minutes fighting the drift. It did land in a bush about 1m high and lost a prop. I was flying in close quarters. I refitted prop and it flew again but continued to drift. I put it away. Next time I flew it went up fast and uncontrollably. Got worse from then.
3. It flips to the left on take off. Up throttle only. This was random. It then began to head upwards fast and randomly. I haven't flown it since for fear of losing it. I run it holding it in my hand with or without props. On a CSC start it will idle slowly and regularly. The moment I use the throttle, then let the stick go, it revs randomly on its own.
4. I will check temperature of motors.
5. The app tells me its the latest software. App is Version1.3.0.0

Yep, the right rear IR transmitter is faint red and purple pulsing on a cell phone camera.

IMU Calibration done flat steady and cool, with props or guards.

I'm using Android App.
  • Clearing the app's cache/storage No, I don't know how to, but I assume reinstall will do this.
  • Uninstalling/reinstalling the app I will try this
  • Resetting the Tello's Wi-Fi connection Done this many times
  • Flying in Airplane mode Don't know how to do this
  • Using a hardline OTG connection to a controller rather than Bluetooth Not sure how to do this
  • Flying with @volate!lo's TelloFPV demo/full app? Full app I think

What is "FC/ESC issue" How long is warranty?


Thanks for your help with all this.

Bryan
 

ZWActual

Well-known member
Joined
Jul 8, 2019
Messages
384
Reaction score
204
Location
Witless Protection
@bcossart

Bit perplexing, as you stated the Tello was shelved for two months yet multiple symptoms appeared on the first flight...

Drifting and not holding position is indicative of a VPS issue. No VPS error messages appear on the app during the (short) flight time? Suggest you try @umanbean's VPS cleaning tips first and report back.

You noted the version of the stock Ryze Tello app (1.3.0.0). Are you using TelloFPV as well? If you're switching between apps during the same flight, the VPS stream can get confused. Best to power down/up the Tello on each app use.

In RC helos, quadcopter FPV units, etc., there is a discrete Flight Controller (FC) and Electronic Speed Controller (ESC). Short of explanation death by PowerPoint, the ESC integrates with the FC to translate throttle (stick) movements to vary the speed (or voltage) of the motors to spin faster/slower. Believe on the Tello, it's all integrated on the circuit board so not something's that replaceable except the board itself.

Here're some reference links to your questions:
Warranty info; Tello Official Website-Shenzhen Ryze Technology Co.,Ltd.
1568769668300.png
 

bcossart

Member
Joined
Sep 16, 2019
Messages
12
Reaction score
0
@bcossart

Bit perplexing, as you stated the Tello was shelved for two months yet multiple symptoms appeared on the first flight...

Drifting and not holding position is indicative of a VPS issue. No VPS error messages appear on the app during the (short) flight time? Suggest you try @umanbean's VPS cleaning tips first and report back.

You noted the version of the stock Ryze Tello app (1.3.0.0). Are you using TelloFPV as well? If you're switching between apps during the same flight, the VPS stream can get confused. Best to power down/up the Tello on each app use.

In RC helos, quadcopter FPV units, etc., there is a discrete Flight Controller (FC) and Electronic Speed Controller (ESC). Short of explanation death by PowerPoint, the ESC integrates with the FC to translate throttle (stick) movements to vary the speed (or voltage) of the motors to spin faster/slower. Believe on the Tello, it's all integrated on the circuit board so not something's that replaceable except the board itself.

Here're some reference links to your questions:
Warranty info; Tello Official Website-Shenzhen Ryze Technology Co.,Ltd.
View attachment 4649
Thanks again. I have just noticed whilst running it in my hand a VPS error in the app. I thought it was my hand in front of the sensors.

Just using the stock Ryze Tello App
 

bcossart

Member
Joined
Sep 16, 2019
Messages
12
Reaction score
0
Thanks again. I have just noticed whilst running it in my hand a VPS error in the app. I thought it was my hand in front of the sensors.

Just using the stock Ryze Tello App
Is the sensor the small hole in the middle. Hard to clean :) Looks OK.
 

ZWActual

Well-known member
Joined
Jul 8, 2019
Messages
384
Reaction score
204
Location
Witless Protection
The VPS system is comprise of the IR emitter/receiver flanking the tiny pinhole camera in the center. The IR LEDs can be cleaned with a soft material but the camera would probably be obstructed by a small particle.

Still no go?
 

bcossart

Member
Joined
Sep 16, 2019
Messages
12
Reaction score
0
Sorry I have just understood the reference to airplane mode. (I thought you meant Fixed wing mode..oops) Is it good to fly with the phone in airplane mode.
 

bcossart

Member
Joined
Sep 16, 2019
Messages
12
Reaction score
0
The VPS system is comprise of the IR emitter/receiver flanking the tiny pinhole camera in the center. The IR LEDs can be cleaned with a soft material but the camera would probably be obstructed by a small particle.

Still no go?
everything looks clean. I wiped them over anyway, nothing in the camera that I can see.
and still no go.
 

ZWActual

Well-known member
Joined
Jul 8, 2019
Messages
384
Reaction score
204
Location
Witless Protection
Yes. Turn ON Airplane mode to reduce Wi-Fi interference from cellular or Bluetooth transmissions.

The phone communicates with the Tello over the same 2.4GHz frequency as Bluetooth which could explain control (& video feed) issues.

Wi-Fi should be on, cellular (4/5G LTE) and Bluetooth off (if physical controller is not needed or connected via OTG).
 

ZWActual

Well-known member
Joined
Jul 8, 2019
Messages
384
Reaction score
204
Location
Witless Protection
You got some serious gremlins with that Tello. :confused:

See this thread. Might need to submit a ticket to Ryze tech support.
 

New Threads

Forum statistics

Threads
3,442
Messages
26,687
Members
8,950
Latest member
daveculp